SAP NetWeaver 7.0 Java Stack Maintenance Ends in 2017

 

SAP’s vendor maintenance for the Java stack in the NetWeaver 7.0 application server is ending on 31st December 2017.  That means there will be no more bug fixes or security updates, so you need to upgrade if any of your SAP systems use it.

SAP software mostly runs on their NetWeaver Application Server (AS) which use either the ABAP or Java programming language.  A Java stack can either standalone or be part of a dual stack that runs both Java and ABAP. 

ABAP is SAP’s own language, and the NetWeaver 7.0 AS ABAP is supported until 2020, so it is not affected.  Java is a widely used language currently owned by Oracle, and support for the NetWeaver 7.0 AS Java ends on 31st December 2017.

NetWeaver 7.0 was first released way back in 2005 and is based on Java version 1.4.2, which was released in 2002. 

Java 1.4.2 reached end of life on 30th October 2008 when public support ended, and Oracle stopped paid support in February 2013.  Java 1.4.2 has security issues and bugs and is not normally suitable for production use since it reached end of life. 

SAP invested in supporting Java 1.4.2 for their customers to maintain the support through to 31st December 2017, but are now ending their support.

You can read more information on SAP’s support of NetWeaver 7.0 AS Java and Java 1.4.2 in SAP Note 1648480.

NetWeaver 7.0 includes the following NetWeaver releases:

  • NetWeaver 7.0 with no Enhancement Package (NetWeaver 7.00)
  • Enhancement Package 1 for NetWeaver 7.0 (NetWeaver 7.01)
  • Enhancement Package 2 for NetWeaver 7.0 (NetWeaver 7.02)
  • Enhancement Package 3 for NetWeaver 7.0 (NetWeaver 7.03)

The following SAP products run on affected NetWeaver 7.0 versions:

  • SAP ERP 6.0 with Enhancement Package 6 or lower
  • SAP SRM 7.0 with Enhancement Package 2 or lower
  • SAP CRM 7.0 with Enhancement Package 2 or lower
  • SAP SCM 7.0 with Enhancement Package 2 or lower
  • SAP BW with a version number less than 7.1
  • SAP PI with a version number less than 7.1
  • Enterprise Portal with a version number less than 7.1
  • SAP Solution Manager 7.1 or lower

If you have any of these products present in your landscape, and they have a Java stack present, you need to consider an upgrade before 31st December 2017. 

If you are not sure, contact Absoft and we will advise if your SAP landscape is affected. 

There is no extended maintenance phase for NetWeaver 7.0 AS Java, so it is vital that you upgrade any affected systems before the 31st December 2017 to avoid being left without bug fixes or security updates.

release upgrade is a major change to your SAP landscape.  You will require a programme of testing and periods of downtime in the project, so there is some business impact.   

SAP recommend that release upgrades are undertaken by an experienced SAP consultant.  There are a lot of technicalities to consider, such as operating system and database support, interoperability and a possible requirement for a dual stack split.  Your internal basis team may have suitable resources to complete the upgrade, or you can consider getting assistance with your SAP upgrade from Absoft.

Before going ahead with any upgrade, I recommend you perform a technical roadmap exercise.  A roadmap allows you to identify any dependencies you need to address before the upgrade, and it might reveal other advantages or efficiency savings you can get from combining other projects to reduce total business impact.  A roadmap also provides indicative costs for projects well in advance, which are invaluable for working with your organisation’s budget planning cycles.

Java Stack Support

The SAP Upgrade Process

Further Benefits of Upgrading

SAP Interoperability and Support

 Dual Stack Split

Want to know more? Read our blog "Why you should eliminate NetWeaver 7.0 from your SAP Landscape" or contact us below.

Make an enquiry button

 

by Robert MacDonald, Senior SAP Consultant