Why you should eliminate NetWeaver 7.0 from your SAP Landscape

SAP NetWeaver is the architecture that underpins any SAP system.  It provides the application servers that allow the SAP software to run and the technical integration between software.

The current version of SAP NetWeaver is 7.4, which is optimised for HANA and features a new Eclipse development environment, enhancements to the ABAP language and HTML5 support for the latest user interfaces. 

By contrast, NetWeaver 7.0 was released in 2004.  Being more than ten years old, it has components facing end of maintenance and compatibility issues with other products.

Do I have NetWeaver 7.0?

Some SAP products like PI, Enterprise Portal or BW are part of SAP NetWeaver itself, so the release of the product is equivalent to the underlying NetWeaver release.  SAP Business Suite products such as ERP, CRM, SRM and SCM run on a particular NetWeaver release for each release of the product.

You may have NetWeaver 7.0 in your landscape if you have:

  • SAP ERP 6.0 with enhancement package 6 or less
  • SAP SRM, CRM or SCM 7.0 with enhancement package 2 or less
  • SAP BW, PI, or Enterprise Portal system with a version number less than 7.3

Reason One to Eliminate 7.0: End of AS Java Maintenance in 2017

SAP NetWeaver provides two application servers: ABAP and Java.  ABAP is SAP’s own programming language, whilst Java is a language owned by Oracle.  SAP software uses both languages, and therefore runs on both application servers.

The SAP NetWeaver 7.0 Java application server uses Java 1.4 which was released in 2002.  Support and security updates for Java 1.4 ended in 2008, but SAP have invested to keep Java 1.4 supported for their NetWeaver 7.0 customers.

SAP have announced they will stop supporting Java 1.4 at the end of 2017, meaning the Java application server for SAP NetWeaver 7.0 will be out of maintenance

Incidentally, the NetWeaver 7.0 ABAP application server will be supported until 2020.  SAP NetWeaver 7.31 and 7.4 are supported until 2025.

Reason Two to Eliminate 7.0: Interoperability with SAP Business Suite

Interoperability is the grand word that SAP use to describe compatibility between different releases of software.   

The latest releases for SAP Business Suite 7i2013 products are:

  • SAP ERP 6.0 Enhancement Package 7 (6.07)
  • SAP CRM, SRM and SCM 7.0 Enhancement Package 3 (7.03)

If you want to use any of these releases, then you cannot have any technical stack in your landscape that is less than NetWeaver 7.3.  That means you must upgrade SAP BW, PI and Enterprise Portal to NetWeaver 7.3 or 7.4 before you can apply the latest enhancement packages to your systems. 

The latest enhancement packages are recommend to get the best from Fiori applications, HANA and the latest functionality in all products.  If your business can benefit from any of this functionality, or you are asked to provide it for them, having NetWeaver 7.0 systems present could seriously increase the work required.

What to do next

A few of our customers who have been keen to use the functionality of Enhancement Package 7 for ERP 6.0 have had larger projects than they expected due to older NetWeaver 7.0 systems present in their landscape. 

We generally produce a roadmap for our customers, which will identify their NetWeaver 7.0 systems and what order they can upgrade them in to ensure they do not breach interoperability guidelines.  If you prepare a roadmap now, you can be aware of the budget and time required in time to plan the project. 

The actual project itself usually consists of a series of upgrades.  A release upgrade of all NetWeaver 7.0 products will be required, followed by any desired enhancement package applications to SAP Business Suite products.

Further Information

If you would like further information, read our blog "SAP NetWeaver 7.0 Java Stack Maintenance Ends in 2017" or contact us below.

Make an enquiry button

 

by Robert MacDonald, Senior SAP Consultant